ERROR: MIN_SIG_SCHEME_FOR_TARGET_SDK_NOT_MET

Antranix

Member
Hello everybody. After the error we had with the latest version was solved, I have generated a new apk to upload it to Google Play and I get the following error.

"You uploaded an APK with an invalid signature (learn more about signatures). Apksigner error: ERROR: MIN_SIG_SCHEME_FOR_TARGET_SDK_NOT_MET: Target SDK version 30 requires a minimum of signature scheme v2; the APK is not signed with this or a later signature scheme"

1623592632018.png
How can I solve that.

Thanks,
 

appyet

Support Team Member
Staff member
after you receive your apk, did you sign it with your own or any third-party signer before upload it to Google Play?
 

Antranix

Member
after you receive your apk, did you sign it with your own or any third-party signer before upload it to Google Play?
Yes, before uploading the apk to Google Play, signed the apk with another program, all my applications are signed before uploading to Google Play. But since the last update something happened and when I upload it throws me that error. I've tried it with other programs to sign and Google keeps showing the same error.
 

appyet

Support Team Member
Staff member
If, before uploading the apk to Google Play, signed the apk with another program, all my applications are signed before uploading to Google Play. But since the last update something happened and when I upload it throws me that error. I've tried it with other programs to sign and Google keeps showing the same error.
Since you are signing your app with third party signer, just make sure your signer support



APK Signature Scheme v2 now required
Apps that target Android 11 (API level 30) that are currently only signed using APK Signature Scheme v1 must now also be signed using APK Signature Scheme v2 or higher. Users can't install or update apps that are only signed with APK Signature Scheme v1 on devices that run Android 11.

To verify that your app is being signed with APK Signature Scheme v2 or higher, you can use either Android Studio, or the apksigner tool on the command line.
 

Antranix

Member
Since you are signing your app with third party signer, just make sure your signer support



APK Signature Scheme v2 now required
Apps that target Android 11 (API level 30) that are currently only signed using APK Signature Scheme v1 must now also be signed using APK Signature Scheme v2 or higher. Users can't install or update apps that are only signed with APK Signature Scheme v1 on devices that run Android 11.

To verify that your app is being signed with APK Signature Scheme v2 or higher, you can use either Android Studio, or the apksigner tool on the command line.
Thanks.
 

Req

New Member
I want to enable lower SDK version.

That is : Minimum SDK Version 19

Instead of the current 21, how do I effect that on my app?

I tried editing it myself to SDK Version 19 but got stuck with SHA key mismatch when uploading to Google play store.
 

appyet

Support Team Member
Staff member
minimum 21 can't be changed, API and features used by application are not available for SDK lower than 21
 
  • Like
Reactions: Req

Req

New Member
But when I changed the minimum SDK to 19 then the WordPress/RRS started working on my modified app, how can I solve that too without downgrading the minimum SDK version to 19?
 

KatyRo

New Member
Using the apps for business is a fantastic idea. You can make your life easier as good as possible today. So why do not do it? I choose wow24-7.io/saas for my business, it is the best outsourcing company I have ever met. Round the clock support makes your company in touch with your clients. So you can keep abreast of all positive and negative feedback.
 
Top