Developer Console rejected updated V3 app

Talkrabb

New Member
Because I could not find a way to upgrade my app from V2 to V3 I made a new one with the same name.
After uploading the app I get the following error:

- The app is signed with a different certificate
- The app has not the same name packet name
(old: org.thaifrau.kontaktanzeigen, new: com.thaifrau.mobi.kontaktanzeigen)
- The version code must be higher than 37 (V3: 5)

How can I modify the V3 app so it is accepted as an update?

Andreas

---------- original German error message ------------
Sie haben eine APK-Datei hochgeladen, die mit einem anderen Zertifikat signiert ist als Ihre vorherigen APK-Dateien. Es muss dasselbe Zertifikat verwendet werden. Ihre vorhandenen APK-Dateien sind mit folgenden Zertifikaten und ID-Dateien signiert:

[ SHA1: 76:6D:3F:4F:48:76:B5:08:94:A4:EF:56:FB:37:5C:18:8C:15:DF:96 ]
. Die Zertifikate, mit denen die hochgeladene APK-Datei signiert ist, weisen die ID-Dateien
[ SHA1: 4F:59:38:BB:5C:64:C6:03:E8:38:C2:80:E9:C7:47:D1:C5:85:C7:BF ]
auf.
Ihre APK-Datei muss den Paketnamen org.thaifrau.kontaktanzeigen haben.

Der Versionscode Ihrer APK-Datei muss größer als 37 sein.
---------------------------------------------------------------------------------------
 

Talkrabb

New Member
I found the following information on stackoverflow:
http://stackoverflow.com/questions/6820688/android-developer-console-app-update

Before uploading the updated application, be sure that you have incremented the android:versionCode and android:versionName attributes in the element of the manifest file. Also, the package name must be the same as the existing version and the .apk file must be signed with the same private key. If the package name and signing certificate do not match those of the existing version, Market will consider it a new application, publish it as such, and will not offer it to existing users as an update.

http://developer.android.com/guide/publishing/publishing.html#marketupgrade

Again: Is there a way to update from AppYet version 2.x to 3.x WITHOUT having to generate a new play store entry and thereby lose my 10000-50000 users?
( https://play.google.com/store/apps/details?id=org.thaifrau.kontaktanzeigen )
 
Google will only accept apk with same package name and incremental version code.
if u create new app that app will have different package name and version code.
 

Talkrabb

New Member
first u should test v3 if every thing is as per ur requirement just upgrade app and upload to play store.
Thank you for the answer.

I already tested the V3 app and it works flawless but I can't find a option to V2 to V3 upgrade.
I also tried to use the same name (org.thaifrau.kontaktanzeigen) when I made the V3 app but it was automatically changed to com.thaifrau.mobi.kontaktanzeigen

What is the correct way to upgrade an existing app?
 

joseph raphael

Well-Known Member
Thank you for the answer.

I already tested the V3 app and it works flawless but I can't find a option to V2 to V3 upgrade.
I also tried to use the same name (org.thaifrau.kontaktanzeigen) when I made the V3 app but it was automatically changed to com.thaifrau.mobi.kontaktanzeigen

What is the correct way to upgrade an existing app?
You are causing the problems to yourself, Delete your V3 and V2 apps. Create a new App with the New package name "org.thaifrau.kontaktanzeigen" and then build your app from ground up. V2 is very different from V3.
 

Talkrabb

New Member
@joseph raphael:

I followed you instructions:
"Delete your V3 and V2 apps"


"Create a new App with the New package name "org.thaifrau.kontaktanzeigen" and then build your app from ground up."


Still no success apart from killing both app versions :-(
 

appyet

Support Team Member
Staff member
We will look into it, what is your original v2 package name which already published to google play

Sent from my SM-G900W8 using AppYet
 

Seppl3

New Member
Hi there,

I have exactly the same problem that Talkrabb has.

1. I have deleted the V2 App that I want to update
2. When I try to create a new one V3 with the same name I get the message "Package name already in use"

I guess this problem does not only affect these 2 users here in the forum, but much more users.

And it is definitely a "big" issue, if you can not update from V2 to V3 and also lose your original APKs cause you erased them as told here in the forum!

Please fix this! It is a really bad situation for us users

Thank you very much!
 
"
- The app is signed with a different certificate
- The app has not the same name packet name
(old: org.thaifrau.kontaktanzeigen, new: com.thaifrau.mobi.kontaktanzeigen)
- The version code must be higher than 37 (V3: 5)"

1. Why's there a different signature issue? Appyet using a new signature in v3? I don't think that they'll do this. It'll kill all updates. Signature should be same in new version apks.

2. This issue still not solved? Looks like even if we delete a previous build, package name will remain in appyet's records and it'll not allow another person to take same package name.

3. Version codes can't be lesser than one you already uploaded. example, if uploaded version is v3.0, you can't upload a v2.0 version.

The last part of the error message is saying that the app you are uploading is signed with a different certificate than your previous version. So appyet really changed signature? If that's the case, only appyyet can help you because only they have the signature. They should change your package name and sign your apk with previous signature.
 
Last edited:

Talkrabb

New Member
Hi Joseph.

On the recommendation of "josep rafael" I deleted my V2 app and tried to generate a V3 version with exact the same settings.
Problem is: I can't. Error message "Package name is already in use, please choose a different Package Name".

Currently there's no app visible in my account.

Only thing I ask for is resetting their database so I can generate a V3 version of the "org.thaifrau.kontaktanzeigen" app that I can upload to the play store without loosing my 30000+ ( https://play.google.com/store/apps/details?id=org.thaifrau.kontaktanzeigen ) installations by creating a new entry in the play store.
 
"(old: org.thaifrau.kontaktanzeigen, new: com.thaifrau.mobi.kontaktanzeigen)"

what's
Hi Joseph.

On the recommendation of "josep rafael" I deleted my V2 app and tried to generate a V3 version with exact the same settings.
Problem is: I can't. Error message "Package name is already in use, please choose a different Package Name".

Currently there's no app visible in my account.

Only thing I ask for is resetting their database so I can generate a V3 version of the "org.thaifrau.kontaktanzeigen" app that I can upload to the play store without loosing my 30000+ ( https://play.google.com/store/apps/details?id=org.thaifrau.kontaktanzeigen ) installations by creating a new entry in the play store.
I understand. But looks like there's another issue. See the last part of google play reply. It's saying that signature doesn't match. If this is true and v2 and v3 have different signatures, then even if you succeed in getting old package name, you can't upload apk as update. So appyet should sign your v3 apk with signature which they used to sign v2. So even if they do this, next time if there's an update, they should do this again to your new version apk
 

Talkrabb

New Member
Yup, there might be an issue with the signature too. However if I can't generate the app at all that's priority B.

If Appyet spends 5-10 minutes they can solve the issue and they will benefit from the adsense/doubleclick revenue in the future. Else I'll have to remove the outdated app..
 
Top